Swedbank degraded performance (SE)

Incident Report for Monthio

Update

Swedbank is slower to respond to our request, which thereby causes a delay when receiving transaction data.

Applicants with this bank will therefore experience a longer loading page when retrieving data.

We are in dialogue with the bank, and we are trying to compensate for the delay on our side.
Posted Jun 22, 2026 - 10:53 CEST

Update

We are continuing to investigate the issue.
Posted Jun 20, 2026 - 10:23 CEST

Identified

Swedbank has had degraded performance, and we are now seeing elevated error calls. Applicants might experience issues connecting to the bank during the application flow.

We recommend that applicants with accounts at the bank try submitting the application later if they experience issues. We will advise them to do so via a banner in the flow.
Posted Jun 13, 2026 - 18:33 CEST
This incident affects: Sweden (Bank integrations).