Nordea degraded performance
Incident Report for Monthio Status
Resolved
This incident has been resolved.
Posted Sep 12, 2022 - 15:11 CEST
Investigating
We are seeing elevated error calls towards Nordea. Applicants might experience issues trying to connect to Nordea in the application flow.

We recommend that applicants with accounts in Nordea try going through the application after normal operations has been restored. We will set up a banner in the application flow, advising applicants to try after the situation has been solved.

We are investigating the issue and will update as we know more.
Posted Sep 12, 2022 - 13:23 CEST